読者です 読者をやめる 読者になる 読者になる

僕のYak Shavingは終わらない

車輪の再発明をやめたらそこには壮大なYakの群れが

tmuxとrbenvを併用する場合は.rbenv/shimsのパスも通してないとバージョン指定できない

tmuxを起動するとruby -vでsystemのrubyのバージョンしかでないし、せっかくgemで入れたRailsも使えないしでなんで?ってなってたのですが、plenvの設定をパクったらいけました。

なんでtmuxを起動した時だけなのか・・・。

$ vi .zshevn
# rbenv
if [ -d ${HOME}/.rbenv  ] ; then
  export PATH="${HOME}/.rbenv/bin:${HOME}/.rbenv/shims:${PATH}"
  eval "$(rbenv init -)"
fi

# plenv
if [ -d ${HOME}/.plenv  ] ; then
  export PATH=${HOME}/.plenv/bin/:${HOME}/.plenv/shims:${PATH}
  eval "$(plenv init -)"
fi

とりま解決。